XTM Cloud v 13.0

XTM Offline Editor

The XTM Offline Editor is a self-contained Microsoft Excel application. It allows you to translate, correct and review offline. The only software that you need to install is a compatible version of Microsoft Excel.

Requirements

Minimum software requirements to run the XTM Offline Editor

  1. Microsoft Windows XP or later

  2. Microsoft Excel 2007, 2010 or 2013 32-bit edition

Tip

The application will run with 64-bit editions of Excel, but with some limitations. We recommend that you install the 32-bit edition.

The application runs with MS Office 2011 for the Mac.

Minimum hardware requirements

Windows PC with a minimum of 512Mb RAM and a Pentium 4 processor or above, Core 2 duo or better preferred.

Using XTM Offline Editor

The XTM Offline Editor works in a similar manner to the online, browser-based version of XTM Workbench. If you have used XTM Workbench, then you will be familiar with the main principles of the XTM Offline Editor. Comments appear as Excel comments, to the right of the target segment column.

Enabling Macros
  1. Select File > Options.

  2. Select Trust Center > Select the Trust Center Settings… button.

  3. Select Macro Settings > Disable all macros except digitally signed macros.

Starting the XTM Offline Editor

After opening MS Excel:

  1. Select Enable editing.

  2. Select Enable content.

Tip

The exact format of the messages will vary depending on the version of Excel being used.

Icon bar

The floating icon bar provides quick access to key functions:

Icon

Function

image671.png

Spell check all target language segments

image273.png

Go to the previous incomplete segment

image272.png

Go to the next incomplete segment

image271.png

Add a comment (this function is also available from the right button click menu list)

image270.png

Go to the previous segment with comments

image269.png

Go to the next segment with comments

image268.png

Go to the next segment with errors

image267.png

Invoke the Find and Replace dialog box

image266.png

Invoke the Setup dialog box to switch on or off auto spell-checking of target segments and to show all terminology and matching comments

image265.png

Show this help

The Go To field

The ‘Go To’ field in the header section allows you to go straight to the selected segment ID:

image681.png
Keyboard shortcuts

Caution

The XTM Offline Editor keyboard shortcuts are different from the online XTM Workbench!

  • Keystroke

Function

  • Tab

Saves the current segment and moves to the next segment.

  • Shift+Tab

Moves to the previous segment.

  • Return

Saves the current segment moves to the next segment and copies the first match, if any, to the target field of the next segment.

  • Escape

Undoes any editing in the current segment and moves to the next segment

  • F1

Open this Help document

  • Control+x

Cut

  • Control+c

Copy

  • Control+v

Paste

  • Control+f

Opens the Find and Replace dialog window

  • Control+g

Opens the Go To Segment dialog window

  • Control+m

Add a translation comment to this segment

  • Control+o

Concordance

  • Control+p

Print

  • Control+t

Copies the source text to the target segment.

  • Control+End

Go to the last segment

  • Control+Home

Go to the first segment

  • Control+Up arrow arrow-up-solid.svg

Go to the previous incomplete segment

  • Control+Down arrow arrow-down-solid.svg

Go to the next incomplete segment

  • Control+,

Go to the previous segment with a translation comment

  • Control+.

Go to the next segment with a translation comment

  • Control+\

Concordance

  • Control+e

Go to the next segment with errors

  • Control+0…9

Inserts the appropriate inline element

e.g. Control+1 = {1}, Control+0 = {10} etc

  • Control+Space

Inserts a hard space character, e.g. {sp}

Using the mouse

Clicking the mouse on the following areas has the following effect:

  • Clicking on

Function

  • Target segment

Opens the segment to reveal any inline element details, terminology, and matching. Places the cursor in the target segment text and selects the whole text.

Use the Tab or Return keys to move to the next segment.

  • Source segment

Copies the source text to the target segment.

  • Any term

Replaces the source term with the target term within the target segment.

  • Any match

Copies the match to the target segment.

Using the mouse right button click

Caution

Clicking the mouse right button while editing a segment has no effect!

Clicking the mouse right button outside of the target cell will bring up the following menu:

image682.png

These menu items are the same as for the icon bar with the addition of the ‘GoTo Segment No:’, Concordance, and Print options.

Printing
To print the page:
  • Use the Control+P keyboard shortcut to bring up the standard print dialog box.

XTM Offline Editor will automatically set the Print range to All and Print what to Selection.

Select the printer and set the number of copies.

Spell Checking

XTM Offline Editor uses the built-in Microsoft spell checker. To spell check all the target segments select the image671.png icon.

Before running a spell check, ensure that the project target language is set as the default editing language.

To do this within Excel, go to File > Options > Language:

image683.png

When you want to spell check the whole project, remember that the Ignore All option only applies to the current segment.

If you wish to ignore specific words for the whole file, add them to a custom dictionary.

To add a new word to a custom dictionary:
  1. In the Spelling popup, select the Options button.

    image684.png
  2. In the Excel Options > Proofing tab, select the Custom Dictionaries... button.

    image685.png
  3. In the Custom dictionary popup, create a new custom dictionary for the project.

    image686.png
  4. Set your new dictionary as the default custom dictionary.

    image687.png

: